Anuncio de fukur

Foro

 

10 posts

Having trouble with Unicode for whitespace glyph (Fontforge)

19/05/2014 a las 09:39

Hello, I'm a newcomer in this forum. I have begun taking up designing fonts because I am planning to do one for my webcomic.

I hope you can help me because I am having trouble with Fontforge and Glypthtracer. These two applications are great, but I was having
trouble with the whitespace glyph (the one you hit with the spacebar) and instead having a blank character, it shows up as a
box between words. I tested my font on Corel and Photoshop and that box appears, but its strange that the box doesn't appear in
wordprocessing applications such as Kingsoft.

I tried adding the glyph with another unicode, but this ends up in error for the other glyphs. And some of the unused glyphs are affected. They are now recognized with a question mark above the glyph.

How do I get around this? What have I done in which the box kept appearing when I hit the spacebar?

OS I'm using Win 7 64 bit. The fontforge I downloaded came from Matthew Petrov.


19/05/2014 a las 10:34

Sounds like the space glyph is missing or is not properly mapped in your font. So the NotDef glyph shows-up.

Editado el 19/05/2014 a las 10:42 por koeiekat


19/05/2014 a las 11:26

The glyph for 'space' should be in the code 32 position, to the left of the exclamation point. It should only be left and right side bearings, and a base line. The only variable is the distance between the bearings; that determines the width of your 'space'.


24/08/2016 a las 02:38

I've been having the same issue with the space glyph in Fontforge. I've set left and right side bearings in the code 32 position. The glyph in preview is showing as an empty white box instead of a grey X so it looks like the width of the glyph has been defined? However when I export the font and set type in indesign it's still coming up as the non-defined glyph box thing? What is going wrong here? It's driving me crazy trying to fix it! (It's my first time using FF though so could easily have missed something). Thanks!

Editado el 24/08/2016 a las 02:40 por kalee


24/08/2016 a las 03:17



24/08/2016 a las 04:14

Thanks! Ok so mine looks the same as the image above, except there is a question mark in a square instead of a space above the glyph in the box. Any ideas what I've done wrong?

Editado el 24/08/2016 a las 04:15 por kalee


24/08/2016 a las 17:30

What is the width ?


02/11/2016 a las 11:08

Hi,

I'm new here and trying out Font forge to make my own fonts. I have the same issue, can't solve the probem, and i was hoping someone here could explain what i'm doing wrong.
I got all the letters finished, but can't insert te space character. Even when i've defined the width, there is still a questionmark in the upper box on slot 32

Here some screenshots for you to view, hopely someone can hep because i'm losing my mind on this.

I thank you all!





02/11/2016 a las 11:20

I had the same problem. So what I did first was I set the width of the character and set the side bearings... and it didn't work... BUT THEN I applied the autohint function and then saved everything (the box with the question mark above the glyph changes from blue or blue sided to plain) and exported the font and it worked fine. So I'm not actually sure what I did, but it worked. It was making me lose my mind too. I hope this helps :-)

Editado 2 veces. Última edición el 02/11/2016 a las 11:22 por kalee


02/11/2016 a las 14:02

Yes we did it ! Thanks Kalee, it works, you made my day :-)



Huso horario CEST. Ahora son las 10:32


 
Política de Privacidad  -  Contacto